• Dear Guest,

    You're browsing our forum as a Guest meaning you can only see a portion of the forum in read-only mode.
    To view all forum nodes and be able to create threads/posts please register or log-in with your existing account.

    TwinStar team

[Release] Improved Models for 1.12

Zerocool

Authorized
Joined
Sep 22, 2014
Likes
159
Location
Athens, Greece
So, depending on your saying that sound pretty weird to me and I download my files again from the provided link in order to see your issues. So, after I finished downloading all files, I right clicked the patch-3.7z.001 and choosed to extract whenever I liked, patch-3.MPQ came out. Same did for patch-6.7z.001 where I got patch-6.MPQ. I moved them under my data folder and launched game. No issues at all.
WoWScrnShot_040218_082430.jpg WoWScrnShot_040218_082521.jpg
Also have a look on how your Data folder should look like.
Capture.JPG
So, after model.MPQ goes by default patch-2.MPQ. Then follows my mod as patch-3.MPQ and Balsh mod as patch-6.MPQ and then the rest of the files. Thats the order should be, since I have also Leeviathans boneless Undead mod, which is named patch-4.MPQ. If for some reason isnt working then something you doing is wrong or as I said something wrong with the client. Try also my WoW.exe files from the link provided a bit above and check again.
 

Draakmis

New Member
Joined
Apr 19, 2016
Likes
3
well I am a mac user, and the mac client down load link from Kronos only gives me a torrent for the windows client. Yes i have Wine and used it for TBC, Wrath, and cata... but its so nice to not have to deal with all that bull shit and play on my mac client. My current one works fine except your mod patch.. so i might just bit the bullet and play with 2004 graphics :(
 

Zerocool

Authorized
Joined
Sep 22, 2014
Likes
159
Location
Athens, Greece
Aha, I see. Why you didnt say so, that you are using a MAC. Well, if I remember correct another user had issues, in order to resolve them I think he renamed patch-6 to patch-4.mpq. Rename the files and also rename extension to lower case too, so they will look like patch-3.mpq & patch-4.mpq. I'll try locate his resolution on the project comments, tho it's going to take a while since comments are too many.
 

Cr0wL0ck

New Member
Joined
Aug 23, 2014
Likes
162
The Highperch wyverns in Thousand needles lack a death, upon death their model just stands idle. My favorite area with improved models is clearly hillsbrad & silverpine it looks so perfect and fitting with the rest. thank you for this patch upgrade.
 

Zerocool

Authorized
Joined
Sep 22, 2014
Likes
159
Location
Athens, Greece
The Highperch wyverns in Thousand needles lack a death, upon death their model just stands idle. My favorite area with improved models is clearly hillsbrad & silverpine it looks so perfect and fitting with the rest. thank you for this patch upgrade.
Yeah, I'm aware. I'll try to see if I can have a fix on that too. Thanks for the info.
 

Zerocool

Authorized
Joined
Sep 22, 2014
Likes
159
Location
Athens, Greece
Some new additions for the last and upcoming patch. Updated some class quest rewards :
Verigan's Fist - Legion model replacement [Paladin's Quest]
Bastion of Stormwind - Legion model replacement [Paladin's Quest]
Skyfury Helm - Legion model replacement [Shaman Quest]
Argent Avenger - Legion model replacement with custom aura [Quest:The Argent Hold]
Argent Defender - Legion model replacement [Quest:The Argent Hold]
Argent Crusader - Legion model replacement [Quest:The Argent Hold]
Lightforged Blade - Legion model replacement [Paladin's Quest]
Moonshadow Stave - Legion model replacement [Druid quest]
Woestave - Legion model replacement [Priest quest]
Moar to come !
 

fichi

New Member
Joined
May 15, 2016
Likes
0
Help me please, I got this problem as seen on the screenshot: Got everything on high have reanabled all settings on high / low at the same time and tryed to change video settings ingame nothing helps. Wonder if its only the gnome and dwarf character creation as someone mentioned.
 

Attachments

Zerocool

Authorized
Joined
Sep 22, 2014
Likes
159
Location
Athens, Greece
Help me please, I got this problem as seen on the screenshot: Got everything on high have reanabled all settings on high / low at the same time and tryed to change video settings ingame nothing helps. Wonder if its only the gnome and dwarf character creation as someone mentioned.
Have a look on how I have setup and use it all the time without having such issues. This effect will appear or more if Vertex Animation shader is off. Even if I use an old vga card I can achieve really decent FPS in heavy gaming environments for example in a raid of 40ppl my FPS is still good. Change your settings as I have set and please inform if you resolve it. If anyone else has to comment another solution or observation please do. The game is supposed to run under full graphics and can handle it pretty much good.
 

Attachments

Zerocool

Authorized
Joined
Sep 22, 2014
Likes
159
Location
Athens, Greece
Another update has arrived. New warrior, mage, rogue and hunter replacements as also a new creature.
Ghamoo'ra - Cata model replacement
Whirlwind Mace/Axe/Sword - WoD model replacement's [Warrior Class Quest]
Hunting Spear - Legion model replacement [Hunter Class Quest]
Glacial Spike - WoD model replacement [Mage Class Quest]
Ebon Mask - Legion model replacement [Rogue Class Quest] (Undead/Human Preview)
Fury Visor - Legion model replacement [Warrior Class Quest]
Razorsteel Shoulders - Legion model replacement [Warrior Class Quest]
See ya soon!
 

Nadveg

New Member
Joined
Apr 16, 2018
Likes
0
Hi ! I'm a new world of warcraft player and they told me about these most up-to-date models. I'm downloading at this point to try to install them. Do you still produce more updates of these models? If so, do I have to download them again and overlap them? Btw, nice job man!
 

Zipzo

Authorized
Joined
Mar 29, 2015
Likes
102
I’m having issues where my game will crash as long as I have the mpqs in the data folder. It seems to always happen when I ride a gryphon. It doesn’t happen when I remove it, so any theories as to why this keeps happening?
 

Zerocool

Authorized
Joined
Sep 22, 2014
Likes
159
Location
Athens, Greece
I’m having issues where my game will crash as long as I have the mpqs in the data folder. It seems to always happen when I ride a gryphon. It doesn’t happen when I remove it, so any theories as to why this keeps happening?
I'll suggest to clear WDB folder always before running the game and give a try with my WoW.exe file and see if you will have same issues. Download it from here : http://www.mediafire.com/file/ct2655j3j3ve4f8/WoW.rar
 

Zerocool

Authorized
Joined
Sep 22, 2014
Likes
159
Location
Athens, Greece
Well for me it was times that I had unexpected crashes with LAA version of the file and times that it worked like nothing happen. At the moment I'm using the one modified for more sound channels, as also mine original wow.exe, and I dont have any issues.
 

Zerocool

Authorized
Joined
Sep 22, 2014
Likes
159
Location
Athens, Greece
The Highperch wyverns in Thousand needles lack a death, upon death their model just stands idle. My favorite area with improved models is clearly hillsbrad & silverpine it looks so perfect and fitting with the rest. thank you for this patch upgrade.
Want to give an update on this issue. The model unfortunately isnt handle by client side, taht means that I tried to isolate the fly path mount model to have the new model version and I didnt succeed. Means that the records are handled by the server so it takes advantage of the same model. So, I have either rollback to the normal model, so both fly path mount and beast work or leave it as it is with the new model but no death animations. Same applies also for the gryphon which it has a glitch combat animations. Please people inform me if you prefer to rollback to the old model for both Wyverns/Gryphons or leave them as it is.
 
Joined
Nov 2, 2014
Likes
30
The lack of death animation I remember was soo much worse on other private servers than Kronos so its definitely server-side thing. Kronos actually has most of them working, on other servers I remember things like wolves going to instant death lying on ground when 0 health. When it comes to wyverns I personally say leave it as it is now. But yeah the static almost like they are frozen in place, looks kinda funny. But its a minor thing.
 

Zerocool

Authorized
Joined
Sep 22, 2014
Likes
159
Location
Athens, Greece
No it isnt that, the wyvern model doesnt have any death animations since it is a fly mount for characters only and not a beast model. It isnt a normal beast model that also made it a mount and includes the death animation.
 
Joined
Nov 2, 2014
Likes
30
Right. I was just talking about death animations in general, for beasts, seem to be a server-side thing since some servers I've played the wolves dont falls down but instantly go from standing to lying on ground, but on other servers it works. But yes okay the wyvern is different, I understand. I still vote for it to stay in game, others can vote what they think :)
 

Asmodeus

Authorized
Joined
Oct 11, 2014
Likes
27
So I was looking through this
I noticed that I don't have a bunch of these models (the new troggs, weapons, some other stuff). Were a lot of these not included in the current release of the patch or did I somehow apply it incorrectly?
 
Top Bottom